CMS Automne

Forum de la communauté du CMS Automne
Nous sommes actuellement le Jeu Août 22, 2019 6:09 am

Le fuseau horaire est UTC [Heure d’été]




Publier un nouveau sujet Répondre au sujet  [ 3 messages ] 
Auteur Message
MessagePublié: Mar Avr 09, 2013 9:49 am 
Hors-ligne

Inscrit(e) le : Lun Mars 07, 2011 5:30 pm
Message(s) : 70
Bonjour

Je veux lister sour forme de <ul><li> les catégories d'un module de produit

mon code

Code :
<atm-function function="categoriesTree" object="{Produit:Rubrique}" root="19" maxlevel="2" disable="60" selected="62">
                     <item><li><a href="{page:listing:url}?pdt={id}">{label}{sublevel}</a></li></item>
                     <itemselected><li><a href="{page:listing:url}?pdt={id}" class="selected">{label}{sublevel}</a></li></itemselected>
                     <template><ul>{sublevel}</ul></template>
                  </atm-function>


Le problème est que cela me sort 2 champs <a /> vide ! correspondant à la catégorie mère au départ de l'arborescence

Code :
<ul>
<li> <a href="?pdt=62">Ma catégorie</a>

<ul>
<a href="?pdt=62"></a>
<li>
<a href="?pdt=62"></a>
<a href="?pdt=63">ma sous catégorie</a>
</li>
<li>
<a href="?pdt=64"></a>ma sous catégorie</a>
</li>
... après c'est ok



Une idée ?


Haut
 Profil  
 
MessagePublié: Mer Avr 10, 2013 10:32 am 
Hors-ligne
Avatar de l’utilisateur

Inscrit(e) le : Sam Fév 12, 2011 5:26 pm
Message(s) : 188
Salut,
Je crois bien que c'est la fonction que je déteste le plus utiliser sur ce CMS.
J'ai toujours l'impression de manipuler une antiquité.
Bon sans comprendre pourquoi cela ne marche pas, déjà j'aurais tendance à écrire le code différemment :

Code :
<atm-function function="categoriesTree" object="{Produit:Rubrique}" root="19" maxlevel="2" disable="60" selected="62">
                     <item><li><a href="{page:listing:url}?pdt={id}">{label}</a>{sublevel}</li></item>
                     <itemselected><li><a href="{page:listing:url}?pdt={id}" class="selected">{label}</a>{sublevel}</li></itemselected>
                     <template><ul>{sublevel}</ul></template>
</atm-function>


J'ai déplacé le sublevel après le a mais avant le /li pour que tes UL s'imbriquent correctement
Pourquoi as-tu un disable sur ta catégorie 60, es-tu sur que ce n'est pas ce noeud qui pose problème ?
Enfin j'en sais trop rien


Haut
 Profil  
 
MessagePublié: Mer Avr 10, 2013 10:59 am 
Hors-ligne

Inscrit(e) le : Lun Mars 07, 2011 5:30 pm
Message(s) : 70
T'es un champion !

merci Manu


Haut
 Profil  
 
Afficher les messages publiés depuis :  Trier par  
Publier un nouveau sujet Répondre au sujet  [ 3 messages ] 

Le fuseau horaire est UTC [Heure d’été]


Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 13 invité(s)


Vous ne pouvez pas publier de nouveaux sujets dans ce forum
Vous ne pouvez pas répondre aux sujets dans ce forum
Vous ne pouvez pas éditer vos messages dans ce forum
Vous ne pouvez pas supprimer vos messages dans ce forum
Vous ne pouvez pas insérer de pièces jointes dans ce forum

Recherche de:
Aller vers :  
cron
Powered by phpBB® Forum Software © phpBB Group
Traduit par Maël Soucaze et Elglobo © phpBB.fr